Announcement

Announcement Module
Collapse
No announcement yet.

Question

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question

    Hi there I was diagnosed in June 2017 and both removed due to finding it in both at the same time. I ended up needing chemo in March 2018 3 rounds of BEP and have been all good since. My last CT and blood work was in March of this year.

    Also end of the last year I was diagnosed with ankylosing spondylitis and started infusions in October of last year but I stop that in February due to my dog getting cancer and we had to pay for treatment.

    So my question in the last week I have been getting pain where my testicles used to be I did speak to my oncologist and she is not to worried due to my scans and blood work being all clear three months ago she thinks it could be surgical pain even though I have not had any surgical pain in 4 years is that possible to have surgical pain 4 years later.

    Has anyone had a relapse and felt pain where there balls used to be thanks again for any advice

  • #2
    four months after the surgery, the pain is still there.
    03.01. 2021 ultrasonic examination detected mass
    03.11. 2021 "Highly suspected seminoma" by MRI report
    03.16. 2021 Left I/O
    03.26. 2021 Seminoma confirmed by pathology report.
    Surveillance...

    Comment


    • #3
      To the best of my knowledge, pain that far from surgery is uncommon, but it's even less common to have a relapse in your scrotum. Did you get implants? Is it possible you might have done something recently to injure that area?
      Jan, 1975: Right I/O, followed by RPLND
      Dec, 2009: Left I/O, followed by 3xBEP

      Comment


      • #4
        No implants were fitted but also with the dull ache in that area i am constantly peeing all the time so was at my local doctors he hade me leave a urine sample and started me on antibiotics for a possible UTI on day 2 of antibiotics the results of the urine test were clear going to see if they work over the weekend and if not will have to go to my Urologist i think would be the next step

        Comment


        • #5
          No implants were fitted but also with the dull ache in that area i am constantly peeing all the time so was at my local doctors he hade me leave a urine sample and started me on antibiotics for a possible UTI on day 2 of antibiotics the results of the urine test were clear going to see if they work over the weekend and if not will have to go to my Urologist i think would be the next step

          Comment

          Working...
          X